Access Point Names switching to default abruptly

Hello Teracube team,

I am on a MVNO(H20) in US which means I have to create Access Point Name(APN) and select it manually to access internet. Even though phone is supposed to remember my selection it falls back to the default one. Some time my change lasts for few hours and some times I have to repeatedly do it multiple times to access the internet. And also the default one is not deletable. Please look into this issue and let me know how should I proceed. Thanks for your assistance.

Hi @Ashwin - could you try few things:


  2. Try “default” or “*” on the new APN type. Found some info here.

Let me know if any of these work. I have ordered a h2o SIM that will arrive tomorrow.

A post was split to a new topic: H2O wireless setup

Update : Here is how to get H2O wireless to work

Hi Sharad, Thank you for your detailed steps.
In the first place I have followed the same steps and selected the “H2o Internet” in the APNs menu, how ever after I go back/close the APN’s page my phone switches back to “ATT Nextgenphone”. This was my issue from day one. May be I wasn’t clear enough in the first place. Hope this makes it clear. Please let me know if you have any further questions.

All settings including name are case-sensitive. Your name here does not match (o of H2o needs to be uppercase - “H2O Internet”). Please make sure you have entered settings correctly keeping lowercase and uppercase in mind.

Yes, I understand. On the phone it’s “H2O Internet” as you have it on your screen.

Here is the video clip capturing the “H2O Wireless” APN configuration on my phone
Here is the clip showing the APN settings after it didn’t work.

Please let me know if I didn’t not following any instructions properly. Thank you.

The settings seemed fine (can’t confirm for sure). Could you try the following:

  1. After hitting save, select “H2O Internet” APN.
  2. Come out of settings.
  3. Select airplace mode to disable all wireless.
  4. Switch off airplane mode.
  5. See if the cellular symbol shows LTE. This is important.

If this does not work, could you take 2-3 screenshots of your H2O APN covering all settings and send a message to me.

I believe the settings seem fine because I can access internet some times when my “H2O Internet” APN selection is persisted(for some time). But some times(more often than not) my selection is not persisted(as you have seen in the video). I think it has more to do with not being able to save my “H2O Internet” APN selection rather than the APN settings/configuration itself. Forum is preventing me from uploading more than one pic. Let me know if you have an email to send the screenshots to. Thank you.

You can send the pics to (and reference this thread). Just to confirm - do you get LTE symbol show up in the status bar?

I have emailed the pics. Yes, LTE symbol shows up in the status bar. Really appreciate resolution for this issue. Thanks.

Hi Ashwin,
I got your APN pics. I see 2 differences in yours vs what is working for us:

  1. You have not set the MMS proxy. Please set it to

  2. Your Bearer it set to LTE. Please set it to “Unspecified”.

Here are the pics from what is working for us for last 4-5 days.

Thank you Sharad. I will update my H2O Wireless APN with the above settings and will let you know if I see the issue again. Thank you for your prompt response and trying out with H2O wireless SIM. Greatly Appreciated!

1 Like