My Teracube's issues...anyone else in this boat?

My phone, wont accept the update. Keeps telling me its up to date, can’t get the upgrade to 10.
Themes wont work and then the phone reboots.
If I’m writing an email or a text, and have to switch over to look at my calendar, I’ve gotta re-write it.
I’ve tried restarting & rebooting, but its not changing how the phone works. Please help.

Can you share the version number of your software. Its at Settings > System > About Phone > Build number.

We have not upgraded to Android 10 yet - the new update is still at Android 9.

The build number is: Teracube_S1_06

Ok - you have the latest software. Switching over should not make you redo your stuff.

  1. I just tried Gmail compose and switching to a different app. Gmail saves my work as a draft. It can be resumed by going to drafts. This is default Gmail behavior.
  2. Messages app stayed on my text compose. It should not lose whatever text you were typing.

Can you take a video of what is happening and share with us as a private message here -

So it allows me to do to get to the Recovery Screen.
There is no steps 5 or 6.
I have to begin it over and nothing happens. I’ve tried it like 4 or 5 times now. Its not doing anything.

Could you please clarify what steps you are trying to do? And what issue(s) are you facing?

So a few days ago, my son got ahold of my phone and changed the pin. Well I guess he did. When I turn on the phone, it requires a PIN and it activitates the phone. Then another PIN request comes up but the first one doesn’t work on this screen. I’ve no clue what it was changed too.

I was told to reset the phone.
So I’m able to get to the reset menu screen. I click on the reset but NOTHING happens. Step 5 is where I’m supposed to see the Android on its side. It doesn’t do that. It just turns off.

So I don’t know what else to do. I’m gonna charge it overnight and try again in the morning. Hoping that it’ll work.

If not, I’ll reach out again.