TWRP for Teracube?

I have not seen anyone post any twrp yet, so, let me ask what have you found to be issues with building it. --assume it is encryption. If that’s it, I can’t help. But other than that, maybe I can do one.

When I receive this phone I can test it out. From the firmware files, I should be able to start a minimum device tree, I will sync to GitHub.

Recent build tools will work with pre-built kernel image. But they complain that pre-built is deprecated and will not work soon. That being said, do you have available kernel source?

simple device tree is now shared on github.

I have not tested the built product, I have not received device yet. If “Blind” testers are willing let me know. I can share test build.


I just received my Teracube, haven’t had a chance to try building TWRP for it yet.

I’ll try it out

1 Like

Where did you get the

Tried booting your zipped file but still ran into trouble:

PS M:\Desktop\platform-tools> .\fastboot.exe boot .\Image.gz
creating boot image...
creating boot image - 9355264 bytes
Sending 'boot.img' (9136 KB)                       OKAY [  0.373s]
Booting                                            FAILED (remote: 'invalid kernel address: not lie in memory')
fastboot: error: Command failed

EDIT: smh, I need coffee. Now I see how this should work. Trying to build an image now.

EDIT2: Hey, @Mr_Mazak, any instructions for building this? I am currently repo syncing all of the omni android 9.0 branch and I made a local manifest file for the Teracube

I have it posted already. But it was on the xda thread.

Here is a link to the post.

1 Like

No mirrors found on your AFH link. Cannot download.

I uploaded again, should work now.

No luck with your image file. Looking to see if TWRP left any logs after I tried fastboot boot twrp.img with your compiled image.

Maybe the “fastboot boot” command does not work with this bootloader. It is a high possibility.

So tell me what you got when you tried?

I know mtk device , with not working recovery partition will not even boot to fastboot. Leaving your only option to be restore with sp-flash tool. Luckily teracube has also provided flash tool room, so … If your up to it. You could try to flash the recovery, instead of only trying to boot it.

So tell me what you got when you tried?

It received the USB payload in fastboot and just rebooted into normal android.

I think it is an error with booting via the fastboot command like you mentioned, especially after looking at the steps for entering stock recovery: How to Enter Recovery Mode

Normally you don’t need to use any power button volume button combination after selecting recovery from the bootloader…

I just tried to install TWRP but it also failed. :-/ Maybe it’s just compatible with the Teracube?

We haven’t gotten a TWRP version compiled for the Teracube yet.

EDIT: The error I am running into building TWRP for the Teracube:

Stack Overflow question posted by me for help.

Same error occurs when trying to use export USE_NINJA=false

Perhaps I am missing proprietary blobs?

1 Like

I’m assuming that flashing the normal TWRP install from their website would risk bricking the TeraCube, is that right? I would love to have TWRP on my TeraCube like I have on my old Nexus 6P running LineageOS. :slight_smile:

1 Like

TWRP will need to be ported to Teracube first - any generic image will not work. Few folks here are making an attempt. If it helps - we can help fund this effort with any external developer(s).


Yeah I just can’t find much information for solving the following error:

ninja: error: 'obj/STATIC_LIBRARIES/bootctrl._intermediates/export_includes', needed 
by 'obj/EXECUTABLES/update_engine_sideload_intermediates/import_includes', missing 
and no known rule to make it

I see you added some lines to the mk file for boot.ctl, the error message is directly related to this mk file change. Try to build first with out these lines and see what you end with.

Not sure that the files needed to make this are in the Omni twrp source

1 Like

Is the default recovery.img provided with the SP-Flash tools?

In case flashing a compiled twrp.img fails I can flash the default recovery.img?

Yes - it is there in SP Flash image

1 Like

Flashing my compiled TWRP image allows me to enter TWRP. Current errors when I tried to make a backup:

Unable to mount storage
Unable to find partition for path '/system'
Failed to mount '/data' (invalid argument)
Unable to recreate /data/media folder
Unable to find partition for path '/system_root'
E:Bind failed
Failed to mount '/data' (invalid argument)
Unable to mount /data/media/TWRP/.twrps
Failed to mount '/data' (invalid argument)
Unable to find partition for path '/system_root'
Failed to mount '/data' (invalid argument)

Boots into android fine.

Gonna try @Mr_Mazak’s boot image again.

Decryption not working. Grabbing logs.

Hitting a dead-end trying to get encryption to work on TWRP:

If I can find the kernel source of the Teracube and compile a kernel with dm-verity disabled in the fstab then maybe TWRP will be able to decrypt the partition without having to flash a newly patched boot.img or otherwise wipe user data.

1 Like