No GPS signal

Hi, i believe have problem with the GPS receiver in the phone. Apps that try to use GPS seems to not receive any data from satellites. The problem causes inconveniences when driving around with car because phone is unable to get exact location, directions, speed ect…
I only get approximate location (probably from Google via mobile masts).

I also downloaded different GPS apps to see which satellites the phone is connected if to any. Seems that none of the apps get any connection from satellites.

I tried to solve this with solutions offered in topics:

No luck so far.
Got this phone brand new about a week ago from my brother who order it via kickstarter. And everything else seems to be working as intended. Have not dropped the phone yet…

Might there be a loose cable in the phone or GPS receiver is fried or have any other ideas?

Have you tried letting it sit outdoors with a clear view of the sky with a GPS app open, and WiFi/Cellular service for about an hour or so?

Might have a badly outdated almanac.

Have you tried a factory reset just to eliminate any software issues. Also make sure that the phone is updated to SW6.

1 Like

Phone was already updated and running Teracube_S1_06.
No luck after more than an hour outdoors before and after factory reset.
GPS is still not working…

Hi @mikski - this is potentially a hardware fault. Please send us an email at with a link to this topic - we will do warranty replacement of your unit.

1 Like