Phone screen not waking up during call (After SW7)

After applying the update, phone screen is not waking up while on call.

You mean while on call, the phone screen is not waking up even when you take it away from your ear, correct? Have you tried with few calls? I ask because sometimes power button is the culprit.

I checked - its working for me. Can you try few things :

  • reboot
  • clearing cache,storage at Settings > Apps & notifications > Phone > Storage.

Other folks who have installed SW7 - is the screen working as expected during a call?

1 Like

True and I tried with the built-in phone app, WhatsApp, Google Voice… All the same.
I’ll try the steps and report back.

It was still doing it. I toggled off then on lift to wake and tap to wake. I made one phone call and it seems to be working fine so far. However, upon checking for system updates, I get this error message: 'Network Connection Failed(Unable to resolve host “fota server”: No Address Associated with hostname)

I did all of that and I’m still having the same issues. The culprit is definitely the new update! This is so frustrating!

Can you backup and perform factory reset. It seems like something got corrupted in your software cache during the update. And this is the only reported case so far. (Hence a factory reset has a high chance of fixing it)

But this will destroy all of my data

Google backup (check to make sure it is on) will bring all texts, contacts and phone settings back. Your photos anyways need to be backed up to Google photos or some other service (good idea in general).

Note : Make sure you remember your google password.

Google backup will also install all your apps but will not configure them for you. So you might have to login again into your banking apps, social media apps, etc.

I wish I would have seen this sooner. My Teracube has been having this same issue since I bought it actually (pre SW7 update). I have already cleared cache and factory reset for an unrelated issue a week ago but it still persists. It’s as if the phone is going to sleep and the proximity sensor is not detecting when I move it away from my face. It works fine putting it up to my ear, but not taking it away. I just chalked it up to a minor inconvenience of needing to press the power button to wake the device in order to end the call (if the other person doesn’t hang up first). It’s very minor for me and I figured I’d just wait until Android 10, but saw this and thought I’d tell you about mine as well.


Thanks for the reply. The problem is also when trying to play an audio clip within messenger or WhatsApp, it just stops on its own. Not sure if the bug is triggering a false move (proximity and/or gyroscope sensors.